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1 Introduction

Bria Professional is CounterPath’s softphone designed specifically for business and enterprise users. It includes 
the features that are standard to Bria—the ability to make VoIP phone calls, to send and receive instant 
messages (IM), to share presence (availability) information, and to exchange files. Bria Professional adds to 
those features the ability to auto-answer incoming calls and support for LDAP.

A system administrator in an enterprise can provision the application remotely (with or without DHCP), and 
automatically install the .msi package across an enterprise.

instant messaging (Standard Telephone Features
The CounterPath Bria Professional has all standard enterprise telephone features, including:

• Call display and Message Waiting Indicator (MWI).
• Speakerphone and Mute.
• Redial, Hold, Do Not Disturb.
• Call history – list of received, missed, and dialed calls.
• Call transfer.
• Call record.
• Auto answer.
• Six-party audio conferencing.
• Three-party video conferencing.

Enhanced Features and Functions
The CounterPath Bria Professional also supports the following features and functions:

• IM and presence using the SIMPLE protocol or the XMPP protocol.
• IM conferencing (Group Chat) via an XMPP account.
• Managed contact list – importing and exporting contacts between Bria Professional and other applications.
• File transfer via an XMPP account.
• File transfer via content indirection (by sending the files to a file transfer server for “pickup” by the other 

party).
• Support for LDAP.
• Automatic detection and configuration of audio and video devices.
• Acoustic echo cancellation, automatic gain control, voice activity detection.
• Support for the following audio codecs:

AMR Wideband (G.722.2), Broadvoice-32, Broadvoice-32 FEC, DVI4, DVI4 Wideband, G.711aLaw, 
G.711uLaw, G.723, G.726, G.729, GSM, iLBC, L16 PCM Wideband, Speex, Speex FEC, Speex Wideband, 
Speex Wideband FEC.
1
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• Support for the following video codecs:
H.263, H.263+ 1998, H.264.

• Automatic selection of the best codec based on the other party’s capability, the available bandwidth, and 
network conditions. Bria Professional switches the codec within a call in response to changing network 
conditions.

• SIP compliance to 3261 SIP standard.
• XMPP compliance as follows:

• RFC 3920
• RFC 3921
Supported extensions:

• XEP-0004
• XEP-0016
• XEP-0022
• XEP-0077
• XEP-0085
• XEP-0092
• XEP-0115

• STUN and ICE NAT traversal. XTunnels for firewall traversal.
• Support for DTMF (RFC 2833, inband DTMF or SIP INFO messages). 
• Support for languages.
2



2 Installation and Setup

2.1 Getting Ready

Multimedia Device Requirements
Bria Professional requires both speakers and a microphone to make calls. Any of the following configurations 
are acceptable:

• External speakers and microphone
• Built-in speakers and microphone
• Dual-jack multimedia headset
• Bluetooth® multimedia headset
• USB multimedia headset
• USB phone. 

Optimized Devices
Bria Professional is optimized to work with the following:

• Actiontec Internet Phone Wizard
• GN Netcom GN 8120 USB and GN Netcom 8110 USBXP
• Plantronics CS50-USB Wireless Office Headset System
• Polycom® Communicator C100S Wideband USB Speakerphone
• TigerJet RJ11 to USB Phone Adaptor (incorporating the Tiger560C)
• TigerJet USB Phone Set (incorporating the Tiger560C)
• Yealink USB-P1K USB hand phone

Video Cameras
Calls made with Bria Professional will work without a video camera, but one is necessary to allow other parties 
to see your image. Bria Professional will work with most USB video cameras.
3
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2.2 Starting Bria Professional
If Bria Professional is not already running, start it as you would any other program: Use the Windows 
Start menu or double-click the desktop icon. Either the Login window or the softphone itself appears. If 
the login window appears, enter the credentials provided by your system administrator.
 

2.3 Configuring Bria Professional
Read this section if your system administrator advises you that you must either configure Bria Professional or 
complete the configuration.

(If your administrator advises you that configuration is already done, go to “Setting up a Contact List” on 
page 5.)

1. Choose File > Account Settings.

2. Create or modify accounts as instructed by your administrator. See the following pages for details. When 
done, return to the Account Settings window and click Apply to register the accounts. Click Close when the 
Status column is “Ready”. 
4
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2.4 Setting up a Contact List
Typically, you will want to create contacts in order to easily make phone calls, send IMs and transfer files. You 
can set up contacts in several ways:
• During a call that you place or receive, you can add the other party to your contact list. See “Handling an 

Established Call” on page 17.
• You can add addresses to the Contact list one by one. See “Adding a Contact” on page 36.
• You can import a contact list from a file or from another application. See “Importing Contacts” on page 38.
• You can create a contact from an entry in the LDAP directory; see “LDAP Directory Tab” on page 49.
For general information on contacts, see “Contacts Tab” on page 35.
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3 Using Bria Professional

3.1 Starting Bria Professional
If Bria Professional is not already running, start it as you would any other program: Use the Windows 
Start menu or double-click the desktop icon. Bria Professional appears. 

Receiving a Presence Request
If availability is enabled, then at any time you may get a Presence Request dialog box. For information on this 
request, see “Availability” on page 42.

  

3.2 Shutting Down
To shut down Bria Professional, click File > Exit, or press Ctrl+Q. Note that clicking the Close button (X) on 
the softphone minimizes Bria Professional to the system tray; it does not exit.
7
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3.3 The Onscreen Softphone 

The Bria Professional Menu

File
• My Profile. See page 51.
• Preferences. These settings control the way that you work with Bria Professional and apply to all accounts. 

See page 52.
• Account Settings. You will work with these settings only if advised to do so by your system administrator. 

See “Configuring Bria Professional” on page 4. 
• Sign Out. To log off and minimize Bria Professional to the system tray. If you click the Bria Professional 

icon in the status bar, the Login screen appears.This menu item does not appear if you have configured Bria 
Professional for no login (page 61).

• Exit. To shut down Bria Professional. You can also exit by pressing Ctrl+Q.

View
• Change the GUI. See “Showing and Hiding Parts of the Softphone” on page 10.

Call panel. 
See page 12.

Bria Professional 
menu. See below.

Address Book panel. 
See page 35.
8
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Contacts
Lets you work with contacts. Everything in this menu except for import and export can also be performed 
directly in the Address Book panel. 

For information on these actions, including import and export, see page 35.

For information on managing blocked contacts, see “Privacy” on page 47.

Actions
Lists the actions that you can perform, depending on the current “state” of Bria Professional. For example, if a 
contact is selected, it lists all the actions that can be performed on that contact.

If your enterprise has configured Bria Professional to display a Workgroup, you can view the Workgroup from 
the Actions menu.

Help
Provides access to various service-related features. 
9
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Showing and Hiding Parts of the Softphone

You can still receive calls when Bria Professional is hidden or minimized. 

If you exit when Bria Professional is minimized or in Deskbar mode; Bria Professional will start next time as 
minimized or in Deskbar mode.

The Deskbar
To display the softphone as a deskbar, click the Deskbar button.

Show/hide Video panel

Show/hide Dial pad

Display as Deskbar. See page 10

Close Call panel (only Call entry field will 
remain). Click again to open.

Show/hide Address Book

Move Address Book to a separate window

Drag to resize

Restore to large view

Close to System Tray

Deskbar
10
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The Deskbar provides a compact GUI for performing many Bria Professional actions. It is assumed that you 
will work in this mode after you are quite familiar with Bria Professional and its features.

Deskbar button

Your availability Switches between Call 
button and End button

Menu changes depending on whether 
there is an entry in the entry fieldEntry field

Restore to main window

Missed calls
11
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3.4 Placing a Call
You can contact someone using:

• A softphone address (for example, kpereira@domainA.com)
• A traditional phone number.

You can place a call when another call is already in progress. There is no limit to the number of calls you can 
make, although eventually the quality of audio and video will degrade because of limitations on the computer. 
We recommend no more than six concurrent calls.   

1. If you have a camera on your computer, decide how you want to handle video for this call:

• The Video panel must be open if you want to send your video immediately. When the Video panel is 
opened, the Video button appears on the Call panel.
(You always have the option of starting the call without video and then adding it later).

• The Video panel can be opened or closed if you do not want to send video. 

2. Place the call. See the table below. 

The new call is added to the Current Calls bar. You will hear a ringing tone while Bria Professional attempts 
to make a connection.

3. Once the new call is established, switch between different calls by clicking the tab in the Current Calls bar.

Redial

Call entry field

Click a button to place the call. If 
the Video panel was open, a Video 
Call button would also appear 
here.

Current Calls bar

Call toolbar

Other calls are on hold

Filter

Open/close Video panel
12
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How From the... Description

Keying Dialpad or computer 
keyboard 1. If another call is currently in progress, click  on the Call toolbar. 

A new Call Entry area appears. The current call is put on hold.
2.  Enter the softphone address or number in the Call entry field using 

the dialpad or the computer keyboard.

For the name, you can enter the entire softphone address 
(kpereira@domain.com) or just the name (kpereira).
As you type, a suggestion for completing the entry may appear. 
Choose the suggestion or keep typing.

3. To make an audio call, click the green Call button or press Enter. 
Even if the Video panel is open, an audio call will be placed.

4. Or to make a video call, open the Video panel and press Video Call.

Drag-and-drop contact or 
previous call

Contacts or History tab in the 
Address Book panel

Drag an entry from the Contacts or History tab. The call is placed 

immediately. (If the tab contains lots of contacts, first use the  field 
to filter the list.)
• If the video panel is closed, an audio call is placed.
• If the video panel is open, a video call is placed and your video will 

be sent as soon as the other party answers. 

Right-click a contact or 
previous call

Contacts or History tab in the 
Address Book panel

Right-click an entry from the Contacts or History tab and choose Call or 
Video Call. The call is placed immediately. 

(If the tab contains lots of entries, first use the  field to filter the 
list.)

Double-click a contact Contacts in the Address Book 
panel

Contacts have a “double-click” action that either makes a phone call or 
starts an IM. Each contact can be configured separately for this action. 
See Table 1 on page 36.

Double-click a previous 
call

History tab in the Address 
Book panel

Double-click an entry. The call is placed.

Redial Redial button Click Options and choose Redial. Or click the Redial button. 
The call is placed immediately (without video, even if the Video panel 
is open).

Right-click an LDAP 
entry

Directory tab in the Address 
Book panel

If you have set up an LDAP directory (page 59), right-click an entry 
from the Directory tab and choose Call or Video Call. The call is placed 
immediately.

(If the tab contains lots of entries, first use the  field to filter the 
list.)

From Outlook If you have set up contacts in Microsoft® Outlook®, you can place a 
call to a PSTN number (but not a softphone address). 
1. Double-click the contact in the contact list in Outlook. The Contact 

dialog box appears. 

2. Click the  in the top left corner and select the phone number to 
dial. As soon as you release, Bria Professional will be brought to the 
front (or will be started) and the call will be placed.

If you cannot make a call from Outlook, speak to your system 
administrator; the account dial plans may need to be revised.
For information on how Bria Professional and Outlook contacts work 
together, see “Exporting Contacts” on page 39.

Dialing Dialpad 1. If the dialpad is not visible, click the Show/Hide Dialpad button.
2. Click the numbers on the dialpad to enter the phone number.
3. Click the green Call button or press Enter.
13
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Placing another Call
To place a new call (without hanging up on the current call), click the Start another Call button. In the Current 
Calls bar, a tab appears for each separate call.

Hiding your Identity
You can hide your identity on a call, so that the other person will not see your ID on their phone.

Click Options > Hide my Number for this Call.  appears on the Call control bar for this call. Place the call in 
the usual way.

Your identity is hidden only for this call. 

Which Account Is Used?
When placing an outgoing call, you can explicitly specify the account to use for that call. Click the Account 
Selection menu and select the desired account.

Once the call is placed, this menu always reverts back to “Auto”.

Start another Call 
button
14
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If You Do not Select an Account – Auto Account

If you have more than one account enabled and if you do not select the account, Bria Professional selects the 
account to use to place the call as follows:

• If a dial plan exists for any account, Bria Professional runs through the dial plans to determine if the dialed 
number matches any of these plans. If a match is found, the account that the dial plan belongs to is used. 
Your system administrator will have already set up suitable dial plans. 

• If there is no match on any dial plans or if no dial plans are defined, then the default account is used. The 
default account is the account listed first in the Account Settings window (page 62).

Encryption
The outgoing call may be encrypted, depending on your security settings. 

• If an encrypted call is established, the encryption icon ( ) appears on the call display. This icon indicates 
that the call is guaranteed to be secure between you and your proxy, and may or may not be secure beyond 
that first hop. 

• If an unencrypted call is established, no encryption icon appears.
• If the call cannot be established with the specified security, the call will fail.

Ending a Call
Click End on the Call panel. Details of the call remain on the call display. To clear the details of the call from 
the display, click Clear. 
15
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3.5 Handling an Incoming Call
Bria Professional must be running to answer incoming calls. (If Bria Professional is not running, incoming calls 
may be directed to voicemail; check with your system administrator.)

Bria Professional rings and information about the incoming call 
appears in the Call entry field. In addition, the Call Alert box appears, 
even if Bria Professional is minimized. For information on call alerts, 
see “Preferences – Alerts & Sounds” on page 53.       

The softphone address of the person calling you is displayed. The 
display name may also appear. 

Ending a Call
Click End on the Call panel. Details of the call remain on the call display. To clear the call display, click Clear.

Auto Answer
To turn auto answer off and on, in the Call panel click Options > Auto Answer. The AA icon appears in the call 
display.

Auto answer is initially configured to auto-answer after one ring, and to send only your audio when the call is 
established. You can change this configuration; see “Preferences – Advanced” on page 61.

Auto answer is automatically turned off when you shut down or log off.

Action From the... Description

Answer Call panel or Call Alert box Click Answer.
If you are on another call, that first call is automatically put on hold. You are 
now talking to the new caller.
Or press Enter (on the keyboard), if Bria Professional is the active application.

Decline Call panel or Call Alert box Click Decline. There will be a busy signal. In some networks, the call will be 
directed to voicemail (if you have this service).

Permanently 
block the caller

Options menu Click the Options button and choose Block this person.

Answer with IM Options menu Click Options and choose Answer with Instant Message. The phone call is 
declined, and instead an Instant Message window appears. Type the message 
and click Send. (Or close the window if you change your mind.)
16
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3.6 Handling an Established Call
While the call is in progress you can:

• Control the audio: use the speakerphone, mute the call, control volume.
• Record the call.
• Put the call on hold.
• Add the caller as a contact.
• Transfer the call. See the next page.
• Add video. Pause and resume video when video is already present. See “Video” on page 20

Show/hide video panel. See page 20

Speakerphone (this button only 
appears if your computer has a 
speakerphone)

Hold

Mute

Volume control

You can do any of these 
even with the call in 
progress. Many of these 
actions are also buttons on 
the Call toolbar.

Quick transfer. See page 18

Place another call (this one will automatically be 
put on hold). See page 14

Conference call. See page 22

Record on/off

Add the current 
caller as a contact. 
See “Adding a 
Contact using an 
Existing Address” on 
page 37.
17
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3.7 Transfering a Call

Quick Transfer
You can set up a list of phone numbers that calls can be transferred to. Then during a call, you can transfer to 
any of these numbers by selecting from a list.

To set up the numbers:

1. Click File > Preferences from the menu. Display the Transfer panel.

2. Enter as many numbers as you want. To enter a new number, click in an empty line. To remove an entry, 
click in the line and delete the number.

Set one of the numbers as the default and click OK.

To transfer a call, click the arrow on the Transfer button and click the number to transfer to. As soon as the 
transfer is made (the other phone starts ringing), the call is disconnected at your end. 

Basic (Unattended) Transfer – Transfer this Call
You can transfer a call to any number, then hang up as soon as you have entered the number. 

1. Click Options > Transfer this Call. The call display prompts for the number to transfer to.

2. Call the target (the person you are transfering the call to) by keying the number.

3. Click Transfer; the message Transfer Successful appears.

Or click Cancel to continue the current call.

Quick Transfer
18
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Attended Transfer – Call then Transfer
You can first speak to the target (the person you are transfering the call to), then click Transfer to complete the 
transfer.

1. Click Options > Call then Transfer. The first call is put on hold and a New call tab appears

2. Call the target in any of the normal ways.

3. When you are ready, click Transfer; the message Transfer Successful appears.

If the target does not want to take the call, simply end the call with that person. The first call is taken off hold.
19
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3.8 Video

Adding Video

Either you or the other party can add video at any time.

To add video, open the Video panel and click Start My Video. When you add video, the other party may (or may 
not) start sending their video to you.

You can add video, even if you do not have a camera, in order to start receiving the other party’s video.

Other Party Adds Video

If the other party starts their video, the Video panel automatically opens and the video is played. You can start 
sending your own video, if desired (and assuming you have a camera) by clicking Start My Video.

Pausing and Resuming Video

If the Video panel is open and video exists in a call, the Start My Video and Stop My Video buttons appear, to 
let you pause and resume video.

If you close the Video panel, your video will stop being sent; you can reopen the panel and click Start My Video 
again.

Show/hide video 
panel

Control video from the Call panel 
or the Video panel

This button only appears 
when video panel is open
20
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3.9 Voicemail
If your service includes voicemail, then when you have voicemail messages, the word “new” appears beside the 
voicemail icon at the top of the phone. Click the icon to automatically connect to voicemail and listen to your 
messages.

Voicemail icon
21
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3.10 Conference Calls

Starting a Conference Call
You can create a conference call starting from one existing call:

1. Click the Conference icon. Bria Professional enters “conference mode” and “Call a conference participant” 
appears on the call display.

2. Place the second call in one of these ways:

• Right-click on a contact and choose Add to Conference Call.
• Type a name or number. 
(Or to cancel the call, click the Cancel button.)

When the second callee answers, the call will automatically be added to the conference.

Or you can start a conference call using all the existing, separate calls:

1. Establish the calls. The calls can be incoming or outgoing, and one or more calls can include video.

2. Click Conference All.

Conference icon Enter phone number for new participant
22
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Managing the Conference

Adding More Participants
You can add more participants to an existing conference in any of these ways:

• Right-click on a contact and choose Add to Conference Call.
• From the tab that contains the conference, click the Conference icon. Place a call by typing a name or 

number. When the callee answers, the call will automatically be added to the conference.
• Place a separate outgoing call in the normal way (by clicking the New Call icon to display a new tab). 

When the call is established, click Conference All. All existing separate calls will be brought into the 
existing conference.

• Accept one or more incoming calls. A separate call will be established for each call. Click Conference All. 
All existing separate calls will be brought into the existing conference.
Whenever you click Conference All, all current established calls are conferenced together; you cannot keep 
any one call out of the conference.

Send an IM
Click the down arrow beside a participant name and choose Send Instant Message.

Removing a Participant
To remove one call from the conference, click the down arrow beside a participant name and choose Separate 
Call from Conference. The call becomes a separate call.

Disbanding the Conference
To break the conference into separate calls, click Options > Disband Conference.

To hang up on everyone, click the End button.

Conference is now established

Click for actions for this participant
23
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Suspending the Conference
To suspend the conference, click the Hold button. 

Audio Controls
Adjusting Volume. Use the speaker adjustment to adjust volume of the sound you are hearing. 

Mute. Click  on the dialpad to prevent the other parties from hearing you. The  icon appears on the call 
display. When you mute, you may also want to stop video feed, if any.

Speakerphone. Click  on the dial pad to put the callers on the speaker phone. The  icon appears on the 
call display.

Video Conference Calls

Starting a Conference with Video
To start a conference with video, make sure that both the existing calls are video calls. Then click the 
Conference button.

Adding Video to an Existing Conference Call
Click Options > Start Group Video. Your video starts immediately.

Or open the Video panel and click Start my Video. 

When you add video, the other party may (or may not) start sending their video to you. You can add video, even 
if you do not have a camera, in order to start receiving the other party’s video.

How Video Is Shared
When you conference two calls together, video continues as it was before the conference call. For example, if 
you were sharing video with one party, and only sending your video to another party, then that is how the video 
will be handled when the conference call is created. 
24
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The conference host serves as the “funnel” for other video. Whatever the conference host is receiving will 
automatically be sent to the other parties. 

Controlling Video
Once video has been added, it can be paused, resumed and stopped in the same way as on a regular conference 
call, by the initiator of the individual “leg” of the conference call.

The conference host does not have special control over the video, and can only add video on legs for which they 
were the initiator.

However, if the conference host pauses or stops video, other participants will no longer receive video, because 
the host is the video “funnel” as described above.
25
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3.11 Instant Messaging
Instant messages are made using softphone addresses. Therefore, you can send or receive an instant message 
(IM) to:

• Any contact who has a softphone address.
• Any party who phoned you from a softphone address.
• Any party whom you phoned using a softphone address.

You may also be able to use an instant message to send files to another party. See page 31.

Sending an IM
1. There are several ways to select the person to send an IM to.

The Instant Message window appears. Or if another Instant Message session exists, a new tab is created for 
this IM session. 

2. Type the message. Include emoticons and formatting, as desired. 

To insert a return in the message, press Ctrl+Enter. (You can control the behavior of Enter and of 
Ctrl+Enter; see “Preferences – Application” on page 52.)

3. Press Send or Enter.

You can press Ctrl+F to search for text in the large message area.

From the Contacts tab in the 
Address Book

Right-click on the contact and choose Send Instant Message. The contact must 
have a softphone address.

An active phone call The person in the active phone call. Click Options > Send Instant Message.

A person on hold In the Current Calls bar, click the arrow next to this call and choose Options > 
Send Instant Message.

From the History tab in the 
Address Book

Right-click on the entry and choose Send Instant Message. 

A separate tab for each IM conversation. 
The active conversation appears in bold.
If a message comes in on a hidden tab, the tab flashes.
Click the button to close one conversation.

Click to perform one of these actions 
for the active conversation.

Message input area

Click to show recent messages 
26
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Receiving an IM
When an IM is received, either the IM window or a Call Alert pops up. (To control which window appears, see  
“Preferences – Application” on page 52.)

If the IM window is already displayed with an IM session with another person, the message from the new 
person appears in another tab in that window. (You can set up Bria Professional so that each person has their 
own IM window; see “Preferences – Application” on page 52.) 

Receiving a File as Part of an IM
The other person may be able to send you files within the IM. The file appears as a hyperlink. Click the 
hyperlink to open a Browse for Folder that lets you specify where to save the file.

Sending files within an IM is only possible when using SIP accounts and when your system administrator has 
configured a file transfer server.

Sending a Broadcast IM
You can send an IM to several people at one time. A broadcast IM is not a conference IM. 

• With a broadcast IM, each recipient can reply to the IM, but only you will see these replies; the other 
recipients will not see these replies. 

• With a conference IM, all parties see everyone’s messages and the messages each party sends are seen by 
everyone. See “Conference IM—Group Chat” on page 29.

1. Select the parties from the Contacts tab in one or more of the following ways:

• Select one or more contacts in the usual ways (using Shift-click or Ctrl+click).
• Select one or more groups in the usual way.

2. Right-click and choose Send Broadcast Instant Message. The Send Broadcast Instant Message window 
appears.
27
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3. Type the message. Include emoticons and formatting, as desired. 

To insert a return in the message, press Ctrl+Enter. (You can control the behavior of Enter and of 
Ctrl+Enter; see “Preferences – Application” on page 52.)

4. Press Send or Enter. The IM is sent and the window closes.

A recipient may send you a response, which will be displayed to you in a regular Instant Message window; 
you will then be in a regular IM with that one party.

You can press Ctrl+F to search for text in the large message area.

Click to add more contacts. Shows the display names of all 
the selected contacts and the individual display names of 
all the contacts in any selected groups. Contacts that do 
not have a softphone address are not included in the list.
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Conference IM—Group Chat
Group chat allows you to exchange instant messages with a group of people in the same session. All people 
must have XMPP accounts configured in order to participate in group chat.

Group chat differs from a broadcast IM in that all parties see everyone’s messages, and the messages each party 
sends are seen by everyone else. In a broadcast IM, each recipient can reply to the IM, but only the person who 
sent the broadcast IM will see these replies; the other recipients will not see these replies.

There is no limit to the number of participants in a group chat. You can also invite more participants during a 
group chat session.

Starting a Group Chat
1. In the Address Book on the Contacts tab, select the desired contacts. Contacts must be online.

2. Right-click the last selected contact and choose Start Group Chat.

Managing a Group Chat

Inviting More Participants
To invite more participants to a group chat, select online contacts from your Contact List and drag them to the 
Group Chat window. Any participant in the group chat can invite more participants.

Leaving a Group Chat
To leave group chat, close the group chat window.

If you have started the group chat and you leave the session, the session continues with the remaining 
participants.

Right-click a name to:
• Start a private conversation
• Remove a participant (if you 

started the group chat)
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Viewing the IM Archive
You can view your recent IM activity for any contact or group chat session. Do one of the following:

• Right-click a contact and choose View Instant Message Archive.
• On the menu, click View > Instant Message Archive. In the Archive window, click the desired contact 

under Conversations With.

Right-click to delete 
all chat history for a 
person. Right-click to delete 

the selected 
conversation or 
conversations.
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3.12 Sending and Receiving Files

Sending Files
You may be able to send files to another contact. The other contact must have the appropriate account. For 
example, if your system administrator has set up your service for file transfer over the XMPP account, then the 
other contact must have an XMPP account.

1. Choose one of these actions:

• Right-click a contact and choose Send Files. After choosing Send Files, a standard Select Files to Send 
dialog box opens. Select the files to send and click Open.
(This menu item does not appear if the contact does not have the appropriate account.) 

• From the IM window, choose Send File. After choosing Send Files, a standard Select Files to Send 
dialog box opens. Select the files to send and click Open.

• Drag a file from a folder to the IM window.
(If neither of these methods work, then you can assume the contact does not have the appropriate 
account.)

 

If you want, you can cancel the file transfer before the other person retrieves the files.
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Receiving Files

Receiving a File as Part of an IM
You can receive files from another party. You do not have to set up to receive files. In other words, to receive 
files, you do not need a file transfer server at your end. See “Receiving a File as Part of an IM” on page 27.

Receiving a File Independently of an IM
Another person may send you files outside of an IM. The following dialog appears, to allow you to save the file.
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3.13 Email
You can send an email to one or more contacts, or to all the contacts in a group.

Select the contact, contacts or group, right-click and choose Send E-mail. An email window opens in your 
default email application, with the “to” line populated with all those contacts who have email addresses (in their 
Contact Profiles).
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4 Using the Address Book

The Address Book panel, which is divided into tabs, provides access to the following: 

• Contacts.
• Call history. See page 41.
• Contact availability (presence). See page 42.
• LDAP directory. See page 49. 

4.1 Contacts Tab

The Contacts tab displays your contacts and lets you specify multiple contact methods for them, including:

• Softphone address 
• Home phone number, business phone number, cellphone number
• Fax number (this is provided for convenience; Bria Professional does not have any fax capability).
• Email

You can identify one of these contacts as the primary contact method. 

Contacts are typically organized into groups. Bria Professional includes built-in groups: “Friends”, “Home” and 
“Work”. You can add more groups, as desired.

Add a Contact

The availability of others. See page 42.

Display all contacts

Display only contacts who are set up for 
Availability and who are currently online

Search field

Select more display options
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Setting up Contacts

Adding a Contact

Click , or right-click a group and choose Add Contact to Group. The Contact Profile dialog box appears. 
See the table on page 39.

Table 1: Contact Profile Fields

Field Description

Contact name Only the display name is required. This is the name that will appear in the call display and the 
Call Alert when this person phones you.

Group Either:
• Choose one group.
• Click More and select several groups. The new contact will be added to each group.

Ring tone Choose a ring tone for this contact, or use the preferred sound (which is defined in Preferences > 
Alerts). Click the arrow to play the currently selected ring tone.

Contact Methods Enter as many contact methods as you want. Email and softphone entries must have the format 
<name>@<domain>

Advanced The Advanced dialog appears, showing all the addresses for the contact. See below.

Double-click action Choose the desired method. This method will be used when you double-click this contact. 
For example, if you choose “IM:kpereira@domainA.com”, then double-clicking this contact will 
open an IM window using this address (rather than any of the other addresses that exist for this 
contact).

Other fields Complete as desired.

This button is always displayed for 
a new contact. It also appears 
once you enter a new address for 
an existing contact.
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Contact Profile — Advanced Dialog
This dialog lets you fine tune the presence sharing information for this contact and change the account that each 
address is associated with.

Presence Sharing

You can configure which accounts will be used for presence sharing: none, some or all. 

• If you disable all items, this contact will not have an availability icon beside its name in the Contact list.
• If you enable at least one item, the availability icon will be gray; later its color will change to indicate the 

current availability. 

Associated Account

You can change the account that an address is associated with. 

The associated account will be used for sending IMs and for sharing presence information. This means that the 
associated account must be enabled in order to use the address for IM and presence sharing.

The associated account will not be used for placing phone calls; phone calls select the account using a different 
rule; see “Which Account Is Used?” on page 14.

The associated account must be an enabled account of the correct protocol (a SIP account for an address in a 
softphone slot, an XMPP account for an address in a Jabber slot). Bria Professional makes the initial association 
by trying to match the domains. If that fails, it will select the first enabled account of the appropriate protocol. If 
no appropriate account is enabled, the association will not be made (the Account will show as “Unavailable”).

Adding a Contact using an Existing Address
You can add a contact by capturing existing information:

• If you are on a phone call with a person who is not a contact, click the Add to Contacts in the call panel.
• If you are in an instant message session with a person who is not a contact, click the Add button.
• On the History tab, select an entry that is not a contact. Right-click and choose Add as Contact.

The Add a Contact dialog appears. 

If the user portion of the address matches the user portion of an existing address, the Update option is 
automatically selected. For example, if the address is kpereira@domainB.com and there is an existing contact 
an address of kpereira@domainA.com. Otherwise, the Create option is automatically selected.

Take the appropriate action:
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• Create a new contact: Click Create. Change the display name, contact method, and group if desired. Click 
OK.

• Update an existing contact. Click Update. Choose a different contact, if necessary. Change the contact 
method and group, if desired. Click OK.

If the contact method is Softphone or Jabber, an online status request is sent to this person.

Importing Contacts
You can populate the Bria Professional contact list by importing from an external file or files. Your system 
administrator may have placed a file on a server for you to import. You can also import your own file or files, as 
many as required. The new contacts will be added to the existing contacts. 

You can import a contact list from:

• A comma-separated file. Use this method to import from a Microsoft® Excel® file. You will first have to 
set up the file; see below. 

• A Microsoft® Outlook® or Microsoft® Exchange contact list (a *.pst file).
• A vCard file (*.vcf file). A vCard is an electronic business card that is often attached to an email.

1. From the main menu, click the Contacts menu and choose Import Contacts. The Import Contacts wizard 
starts. 

2. As soon as you click Finish on the wizard, the Contacts tab in Bria Professional is updated to show the 
imported entries. Note that none of the entries are set up with availability turned on; in order to view 
availability of contacts, you must modify the appropriate entries by viewing the contact’s Profile and 
clicking the Advanced button. See “Contact Profile — Advanced Dialog” on page 37 for details.

Setting up an Excel File for Import

1. Remove any introductory text or headings from the top of the file. (You can keep text at the end of the file; 
it will be ignored during the import.)

2. Insert a blank row as the first row, then insert the headings that Bria Professional will use to interpret the 
meaning of each column. The columns can be in any order. The most popular headings are:

• display-name
• entry_id
• given_name
• surname
• postal_address.
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For a complete list of headings, see “Contact List Headings” on page 64.

3. Save the file as *.csv.

External Storage of the Contact List
Each time Bria Professional is started, the contact list is retrieved from the external storage. Each time a contact 
is added to the contact list, it is immediately copied to external storage. 

The list is always stored on the local computer. In addition, if you have access to a remote storage server, you 
can configure Bria Professional so that the contact list is also stored remotely using XCap or WebDAV. 

Exporting Contacts
You can export a contact list to a comma-separated file, a pst file or a vcf file.

1. From the main menu, click the Contacts menu and choose Export Contacts. The Export Contacts wizard 
starts. 

2. When you click Next, the export starts. The result is:

• For an Outlook export, the existing .pst file is updated to include the entries from the Bria Professional 
contact list. If Outlook is open, the entries immediately appear in the contact list. 
All information in the Bria Professional contact list is exported to Microsoft Outlook. Only information 
that can be displayed in Outlook actually appears in the Outlook Contacts window. Typically this 
means that all softphone addresses are exported (and stored in custom fields) but not displayed in 
Outlook.

• For other formats, a new file of the specified type is created.

Managing Contacts

Changing Contact Information
To change the information for a contact, right-click the contact and choose View Profile. The Contact Profile 
dialog box appears (see page 36). Some of the changes you can make are:

• Change any contact details.
• Add, delete or change a contact method.
• Move a contact to another group by selecting a different group.
• Add an existing contact to more groups by selecting one or more extra groups.
• Display the Advanced dialog to enable or disable availability information for this contact; see “Contact 

Profile — Advanced Dialog” on page 37.

Moving or Deleting a Contact
• To drag one or more contacts to a different group, select them and drag to the new group.
• To delete one or more contacts, select them, right-click, and choose Delete. The contacts are removed from 

this group. 

Adding, Deleting or Renaming Groups
Select any group, right-click, and choose the appropriate menu item.

Contacts that have no group appear under “Ungrouped Contacts.” You can delete, but not rename, this group.
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Using Contacts

Contact Flyout
Left-click on a contact to show the Contact flyout. This flyout shows all the contact methods set up for the 
contact and has icons you can click to perform an action that is valid for that contact method.

Finding a Contact

If the contact list is long, use the  field to filter the contacts that are displayed. To clear the filter and display 

all contacts again, click  .

Phone or IM the person • Double-click the contact to start a phone call or IM to the person 
(depending on how double-clicking is configured in the contact’s 
profile).

• Drag the contact to the call display to start a phone call.

Phone the person Right-click and choose Call, then click the desired number.

Send an IM Right-click and choose Instant Message. See page 26.

Start a Group Chat session Right-click and choose Start Group Chat. See page 29.

Call a contact and include video Right-click the contact and choose Video Call. The Video panel opens, and 
the call is placed. As soon as the other party answers, Bria Professional starts 
sending your video.

Email a contact who has an 
email address

Right-click and choose Send E-mail.

You can watch the contact’s 
availability, if the contact has a 
softphone address

See Table 2 on page 45 for the meaning of the availability icons. 

See “Availability” on page 42 for information on obtaining availability 
information.

Click an icon to perform the action. 
This contact is online on their 
domainA account but offline on 
their domainXMPP account
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4.2 History Tab

Managing the Lists of Calls
You can right-click on an entry in a list to:

• Delete the call.
• Delete all entries in this list.
• Block this person to control whether they can send you phone calls or instant messages, or see your online 

availability. You can change these privacy settings at any time; see page 54.
• View their profile if the entry is a contact.
• Add to contacts. Select Add as Contact to display the Add a Contact dialog box. Complete the dialog box 

and click OK. For more information on the fields, see “Adding a Contact using an Existing Address” on 
page 37.

Phoning and Sending IM from a List
You can right-click on an entry in the Received or Dialed list to:

• Place a call to this person, using the contact method that was used for this call. You can also double-click to 
place a call.

• Place a call to this person and add them to a conference call that is in progress. For more information on 
conference calls, see “Conference Calls” on page 22.

• Send an instant message, if the call was made with a softphone address. For details, see page 26. 

Display all calls

Dialed calls

Missed calls

Received calls

Incoming missed 
(Missed) or blocked 
(Rejected)

Incoming call that was 
answered

Outgoing call. If answered 
status shows duration. If 
not answered, status is 
“Dialed”.
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4.3 Availability
Availability refers to the ability to see whether a person is available or not: online, on phone, busy, and so on. 
Your availability information is displayed below on the main menu. The availability of others is displayed in the 
Contacts tab. 

You can publish your availability to contacts who have softphone address, and you can set up Bria Professional 
to view the availability of other contacts.

If the contact has several addresses, you can look at their profile for information on which addresses are 
currently online:

Your availability

Availability of other people

This person may be 
logged out

This contact is currently online on their 
domainA account. This account supports 
phone and IM.

The contact is not online on their 
domainXMPP account. This account 
supports IM but not phone.
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Sharing Availability

Watching Others’ Availability 
When you create a contact by entering details in the Contact Profile, the contact is automatically set up so that 
you share availability. If you created a contact by importing a contact list, it is not automatically set up to 
shared. You must display the Contact Profile and click the Advanced button. See “Contact Profile — Advanced 
Dialog” on page 37.

As soon as the person is set up in this way in your Contacts, Bria Professional sends them a notification request. 
The request asks that you be able to see that person’s availability. If the person allows this request, then the icon 
beside their name (in your Contacts) becomes color coded, so you can determine their availability. 

Allowing Other Parties to See your Availability (Publishing your Availability)
Continuing from above, when the other person allows the notification request, your name is added to their 
contact list. As soon as you are added to their list, a request is sent back to you requesting that they be able to 
see you. You can reply to this request to complete the sharing loop.

The following chart illustrates how the sharing of availability occurs.

Receiving a Presence Request
Your Bria Professional receives a new contact request when you add a contact to your list or when another 
person adds you as a contact at their end.

The request is handled in one of two ways:

• If you set up a privacy rule before this person has a chance to contact you, then you will never see this 
request. Bria Professional will automatically reply to the request according to the rule. See “Preferences – 
Privacy” on page 54.
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• If you do not yet have a privacy rule set up for this person or for their domain, this request appears to you as 
a Presence Request. You must respond to the request:
• Block the request. This person will not be able to contact you from this address.
• Allow the request and create a new contact using this address.
• Allow the request and add this address to an existing contact (if Bria Professional has found an 

appropriate match).

For important information on how privacy affects availability, see “Privacy” on page 47.

Button Next Action Result

Allow and Add to 
Contacts

This button appears only if the other person is 
not already on your contact list. 
When you click this button, the Add a Contact 
dialog box appears. Complete the dialog box 
and press OK. For more information on the 
fields, see “Managing Contacts” on page 39. 

The other person will:
• Be able to see your availability. 
• Be added to your Contacts. 

In the future, you will not receive this request from this 
person.
In addition, this same request will be sent to the other person, 
so that you can see their availability. 

Allow The other person will:
• Be able to see your availability, but for this session only. 

Because you have not set up the person as a contact, a 
Presence Request will appear for this person each time you 
start Bria Professional. 

Block The other person will:
• Not be able to see your availability. 
• Not be able to phone or IM you.
• Be added to your Blocked List. See “Preferences – 

Privacy” on page 54.

Close the window The other person will not be able to see your availability. The 
other person will not be added to your privacy settings.
The Presence Request may appear again in this session or a 
future session
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Setting your Availability

Changing your Availability
Click the down arrow beside the availability indicator on Bria Professional, and select the desired availability. 
See Table 2, below.

When your availability changes, the new availability is sent to everyone who has permission to see your 
availability, according to the Privacy Settings (see “Preferences – Privacy” on page 54).

Setting up Availability Indicators
You can create custom availability indicators, or edit or delete custom or built-in indicators: click the down 
arrow beside the availability indicator, and choose Custom Message.
 

Table 2: Availability Indicators

Indicator Meaning for your Availability Meaning for Others’ 
Availability

Available Either:
• You have set your availability to this status. 
• Bria Professional has determined that you are logged on but not on the 

phone or idle.

When you have this availability, Bria Professional will automatically 
detect when you are idle or on the phone, and change the availability to 
match.

You can contact this person.

Busy You have set your availability to this status. Bria Professional will never 
automatically switch you out of this status; you must switch yourself.

You can contact this person.

On the phone Either:
• You have set your availability to this status. In this case, Bria 

Professional will never automatically switch you out of this status; 
you must switch yourself.

• Bria Professional has detected that you are on a call. When your call 
finishes, your availability reverts to the last availability.

You can contact this person.

Not available 
for calls

You have set your availability to this status. Bria Professional will never 
automatically switch you out of this status; you must switch yourself.
Incoming phone calls will be directed to voicemail.

Your phone calls to this person 
will be directed to voicemail. 
You can IM this person.
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Do not disturb You have set your availability to this status. Bria Professional will never 
automatically switch you out of this status; you must switch yourself.
Both incoming phone calls and incoming IMs will be directed to 
voicemail.
However, you can still make phone calls and IMs. When the other person 
responds, your availability will remain as Do not disturb. 

You cannot make phone calls 
or IMs to this person.

Idle You have not moved or clicked the mouse or pressed a keyboard key for 
the Idle period. To set the Idle period see “Preferences – Application” on 
page 52.
As soon as you click the mouse or keyboard, your status changes to 
Available.

You can contact this person.

Away You have set your availability to this status. Bria Professional will never 
automatically switch you out of this status; you must switch yourself.

You can contact this person.

Offline Not applicable The contact is either not 
logged on or else is not set up 
for availability. 

Table 2: Availability Indicators

Indicator Meaning for your Availability Meaning for Others’ 
Availability
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4.4 Privacy
You can control how contacts and other people can contact you by phone or IM, and you can control whether 
your contacts can see your availability information (whether you are online, one the phone, and so on).

You can set up controls in advance or “on the fly” (as phone calls and presence requests come in).

Setting up Controls in Advance
To set up controls in advance, see “Preferences – Privacy” on page 54.

Setting up Controls “on the Fly”

On an Incoming Call
To block someone when they are phoning you, choose Options > Block this Person. 

The call is declined, and this person is added to your Blocked List (see page 54). In addition, if the person is a 
contact, then “blocked” appears beside their name in the contact list. 

You will no longer see incoming calls or instant messages from this person; they will automatically be declined. 

To later unblock this person, remove them from your Blocked List. Or, if the person is a contact, right-click 
their name on the contact list and choose Unblock this Person.
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On an Incoming IM
To block who sends an IM, choose Options > Block this Person on the Instant Message window. Then close the 
window. 

The other person gets a message that their instant message has been declined.

This person is added to your Blocked List (see page 54). In addition, if the person is a contact, then “blocked” 
appears beside their name in the contact list. 

You will no longer see incoming calls or instant messages from this person; they will automatically be declined. 

To later unblock this person, remove them from your Blocked List. Or, if the person is a contact, right-click 
their name on the contact list and choose Unblock this Person.

Via the Presence Request Dialog Box
Another party can send you a presence request, to request that they be able to see your availability, as described 
on page 42.

Your response has the following effect on privacy:

• If you add the person as a contact, then the ability of that person to phone or IM you is controlled by your 
privacy settings; see “Preferences – Privacy” on page 54.

• If you allow the person without adding them as a contact, then the ability of that person to phone or IM you 
is controlled by your privacy settings; see “Preferences – Privacy” on page 54.

• If you block the person, then that person is added to your Blocked List (see page 54). The person will not be 
able to phone or IM you, and will not see your availability information. You can change this blocking by 
removing the person from the Blocked List, in which case they will then be controlled by your privacy 
settings.

From the Contact List or History List
Right-click on the name and choose Block this Person. The person will be added to your Blocked List (see 
page 54). The person will not be able to phone or IM you, and will not see your availability information. 

To later unblock this person, right-click on the name and choose Unblock this Person.
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4.5 LDAP Directory Tab
The Directory tab appears only if you have set up to use LDAP, as described on page 59. 

Phone a Person
Right-click an entry and choose Call or Video Call. The call is placed immediately. 

Create a Contact
Right-click an entry and choose Add as Contact. The Contact Profile window appears, populated with all the 
information from the directory (not only the information displayed in the tab).

Complete the window with any missing information that you want to record and press OK.

Only one number appears for each entry. 
There may be other numbers that will show 
if you try to call this person.
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5 Configuring Bria Professional

You can configure Bria Professional in several ways:

• Set up your personal profile. See below.
• Configure global behavior. See “Configuring Preferences” on page 52.
• Configure the behavior on a per-account basis. See “Configuring Accounts” on page 62.

5.1 Configuring your Profile

To set up information about yourself, choose File > My Profile.
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5.2 Configuring Preferences
Choose File > Preferences. The Preferences window appears. 

The Preferences panels let you control the way that you work with Bria Professional. 

Preferences – Application

This panel lets you set your preferences for general GUI behavior. 
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Preferences – Alerts & Sounds

This panel lets you control the Call Alerts box and lets you assign sounds. 

Showing Call Alert Box

You can control whether the Call Alert box is displayed in different situations.    

   

Assigning Sounds

You can assign specific sounds to a variety of actions or “events”.

1. Select the Enable sounds check box and select the check boxes for  
each desired event, or clear the Enable sounds check box to 
disable all sounds.

2. If enabling sounds, you can change the sound for each event: select the individual event. The value in 
Sound preference will change. Select the desired sound.

Keep in mind that you can also override any sound for an individual Contact; see page 36. 

You can import sounds; these will be added to the list of sounds you can choose from when assigning a sound to 
an event.
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Preferences – Privacy
You can control how contacts and other people can contact you by phone or IM, and you can control whether 
your contacts can see your availability information (whether you are online, on the phone, and so on).

Choose one.
If you choose “Only people on my 
contact list,” then all contacts will be 
able to contact you unless they or their 
domain are in the Blocked list (below).

This section is optional. It lets you 
enter addresses and domains that will 
be prevented from contacting you.
You can add and remove entries from 
the blocked lists.
In addition, entries are automatically 
added to this list when you block 
someone “on the fly” (page 47).

If you enter a domain in this list, 
people in that domain will 
automatically be allowed to see your 
availability online.
You will no longer see Presence 
Request dialogs from these people in 
this domain. 
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Preferences – Quick Transfer

This panel lets you set up a list of phone numbers that calls can be transferred to. Then during a call, you can 
transfer to any of these numbers by selecting from a list.

Enter as many numbers as you want. To enter a new number, click in an empty line. To remove an entry, click in 
the line and delete the number. Set one of the numbers as the default.

See “Quick Transfer” on page 18 for information on using this feature.
55



CounterPath Corporation
Preferences – Devices

Bria Professional automatically detects devices at each startup, and selects the most appropriate device for each 
purpose. If you do not like this selection, you can override it on this panel.

If you override a selection, it will apply the next time you start Bria Professional, unless the device is no longer 
available, in which case Bria Professional will again select the device to use.
56



Bria Professional 2.4 for Windows User Guide
Field Description

Headset Mode

Speaker 
Microphone 

Change these fields only if you want to override the devices that Bria Professional automatically 
selected.
In both these fields, select the headset you are using.
The headset is the device that is usually used for audio out (the sound you hear) and audio in 
(recording your voice). The only situation in which the headset is not used is when the Speaker 
Phone button on the dialpad is pressed. 
Therefore, unless you will always be using Bria Professional in speakerphone mode, you must make 
a selection here.
Select the headset in both the Speaker device field and Microphone device field.

Speakerphone Mode

Speaker Change this field only if you want to override the devices that Bria Professional automatically 
selected.
Make the appropriate choice:
• Select the device that you want to use for audio out (the sound you hear) when the Speaker 

Phone button is pressed. Make sure you select a speaker device (not the headset).
• Select None if you do not have a speaker phone. The Speaker Phone button on the dialpad is 

disabled.

Microphone Change this field only if you want to override the devices that Bria Professional automatically 
selected.
Make the appropriate choice:
• Select the device that you want to use for audio in (recording your voice) when the Speaker 

Phone button is pressed. 

It can be any microphone: it does not have to be the microphone on the device you specified as 
the speaker device. For example, it can be the microphone on your camera. 

• Select None if you do not have a speaker phone. The Speaker Phone button on the dialpad is 
disabled.

Reduce background noise Automatically attempts to remove background noise.
Typically on for the speakerphone.

Phone Ring Device

Device Change this field only if you want to override the devices that Bria Professional automatically 
selected.
The device where you want to hear the phone ringing: the headset, the speakerphone, or none.

Volume The volume of the ringer.

Also ring PC speaker Click on or off, to suit your preference.

Camera

Camera This field appears only on versions of Bria Professional that include video functionality.
Change this field only if you want to override the devices that Bria Professional automatically 
selected.
Select the camera model.
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Preferences – Network

Field Description

Network Connection Speed Select the type of network connection for your computer.
The sliders move to show the bitrate that will be used for sending and receiving. These rates are 
typical rates for the selected configuration.
If you know that your computer and network can handle a faster sending speed, click Custom 
and move the slider.
It is recommended that you not change the receiving speed.
You will know that you have set the sending speed too high if:
• The remote video shows black areas or is slow or jerky.
• The remote audio is garbled.

You will know that you have set the sending speed too low if the audio is good but the video is of 
poor quality (grainy).

Video Image Quality Leave at standard, or change the size as follows:
• Set it to high if you have a good camera and a computer with a fast CPU. You will know that 

you have set the size too large if:

Your computer slows down (the video is using too much CPU)
The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, for example, when using wi-fi in a hotel. You 
will know that you have set the size too small if the video is fuzzy.

Preserve bandwidth When this feature is on, Bria Professional stops sending audio when you are not talking.
When this feature is off, Bria Professional always sends audio, which uses more bandwidth but 
may result in better call quality.
Typically off. However, if you are using a slow (dial-up or ISDN) connection, you may want to 
turn it on. 
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Preferences – Audio Codecs
Change the settings on this tab only if advised to do so by your system administrator.

Preferences – Video Codecs
Change the settings on this tab only if advised to do so by your system administrator.

Preferences – Quality of Service
Change the settings on this tab only if advised to do so by your system administrator.

Preferences – LDAP
Change the settings on this tab only if advised to do so by your system administrator.

Preferences – Contact Storage
Change the settings on this tab only if advised to do so by your system administrator.
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Preferences – Diagnostics

This panel lets you enable logging to files. Logging uses computer resources, so you should only enable it when 
instructed by a customer support representative.

To set up logging:

1. Click Enable diagnostic logging. 

2. Set the logging level. 

3. Specify the folder where logs will be saved.

4. Click OK.

Activity on Bria Professional will be logged to.csv files in the specified folder. A new set of files is started each 
time you log on. In order not to create large files when logging (which may create computer problems), you 
must not remain logged on indefinitely when logging. You should occasionally exit and restart Bria 
Professional.

If requested by a customer support representative, you can:

• Open the logging folder and then open a log file using a text editor. 
• Email the logs in the specified folder to customer support: Click Send logs to customer support. A dialog 

box appears showing all the logs. Select files and click Open; the selected files are sent and the dialog box 
closes.

You can delete log files from the specified folder as you would delete any file on your computer.
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Preferences – Advanced

Field Description

Reduce echoes Turning this feature on improves sound quality. This feature is typically on.

Use slower but more compatible video format Turning this field on may improve performance when running Bria Professional 
on older hardware.

Auto Answer Calls

Auto answer incoming calls From the first set of radio buttons, choose how quickly you want Bria 
Professional to auto-answer an incoming call.

Auto answer with From the second set of radio buttons, choose how you want to handle your own 
video (the video you send), if the other party has placed a video call:
• Auto answer with audio: Your video is not sent. However, if necessary, the 

video panel opens so you can view the other person’s video.
• Auto answer with audio and video: Your video is sent. If necessary, the video 

panel opens, showing both your video and the other person’s video.

Login Server

Change the settings on this tab only if advised to do so by your system administrator.
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5.3 Configuring Accounts

Accounts Settings Window
In general, you will work with the Account Settings window only when advised to do so by your system 
administrator; see “Configuring Bria Professional” on page 4. 
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A Application Hot Keys
Function Keyboard Shortcut

Answer Enter

Exit Ctrl+Q

Hang up Esc

Hold Period

Mute Spacebar
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B Contact List Headings
Following is a list of all the headings that are used in the Bria Professional contact list. This list can be useful 
when formatting a contact list in order to import it intoBria Professional. For details, see “Importing Contacts” 
on page 38

uri business_number sms_addresss

display-name business_number2 ms_address2

entry_id business_number3 sms_address3

given_name business_number4 sms_address4

surname business_number5 sms_address5

email_address business_number6 sms_address6

email_address2 mobile_number custom_fields

email_address3 mobile_number2 custom_fields2

email_address4 mobile_number3 custom_fields3

email_address5 mobile_number4 custom_fields4

email_address6 mobile_number5 pres_subscription

sip_address mobile_number6

sip_address2 fax_number

sip_address3 fax_number2

sip_address4 fax_number3

sip_address5 fax_number4

sip_address6 fax_number5

home_number fax_number6

home_number2 groups

home_number3 comment

home_number4 postal_address

home_number5 default_address

home_number6 default_address_type
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C Location of Files
System files get copied to the installation directory specified when installing Bria Professional. The default 
installation directory is:

C:\Program Files\CounterPath Corporation\CounterPath Bria Professional

Data files are saved in the Counterpath folder in the standard location for application data, as defined in 
Windows.This location is typically: 

C:\Documents and Settings\<user name>\Application Data\CounterPath 
Corporation\Bria Professional\
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D Other Ways to Run Bria 
Professional 

D.1 From a Hyperlink
You can attach a hyperlink to a phone number or softphone address that, when clicked, starts Bria Professional 
and dials the number. Attach a hyperlink with this format:

<a href="sip:<address or number>">dial <address or number></a>

For example:

<a href="sip:kpereira@domain.com">dial kpereira@domain.com</a>

D.2 From the Command Line
You can start Bria Professional from a DOS prompt. You may need to add Bria.exe to the PATH. Then type:

Bria.exe

To start Bria from a DOS prompt and immediately dial a number, type:

Bria.exe -dial=sip:<number>
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E Glossary
AEC Acoustic echo cancellation. Processing of the audio or video signal to reduce the echo 

effect that can arise with a speakerphone or that can arise if the sound from the 
speakerphone or headphone leaks into the microphone. 

AGC Automatic gain control. Processing of the audio or video signal to adjust the 
microphone volume level so that the other party does not hear the distortion that 
might be caused by too high a microphone input or too low volume (due to too low 
input level).

AVI Audio Video Interleave. A multimedia container format. AVI files contain both audio 
and video data in a standard container that allows simultaneous playback.

Broadband Broad or wide bandwidth. In data transmission, the wider the band, the more data it is 
possible to transmit in a given time span. A cable, DSL and ADSL connection to the 
network provide broadband for data transmission. A dialup or ISDN connection 
typically provide a narrow bandwidth for data transmission.

Codec The format by which audio or video streams are compressed for transmission over 
networks.

Default account The SIP account that will be used when placing an outgoing call, if Bria Professional 
does not determine that another account should be used. Bria Professional uses the 
dial plan to determine the account to use. Your system administrator will have 
identified which account is the default. 

Dial plan The rules that Bria Professional follows in order to interpret the softphone address or 
phone number that the user has entered and to modify the number or address, as 
required, to ensure that the call will be placed successfully. 

DTMF Dual-tone multi frequency. DTMF is the system that is used in interactive voice-
response menu systems such as the menu system for accessing voicemail messages. 
The DTMF system allows the user to interact with the menu by pressing keys on a 
dialpad or keyboard.

IM Instant Messaging. A technology that lets users send text message and files for near 
instantaneous delivery and display on each others’ computers.

IP Internet Protocol. A data-oriented protocol used for communicating data across a 
network. IP is the most common protocol used on the internet.

IP address A unique number that devices use in order to identify and communicate with each 
other on a computer network using the IP standard. 

Media In a VoIP phone call, the audio and video portion of the information in a call. 
Compare to “Signaling”.

MWI Message Waiting Indicator. An indicator that there is a voicemail message for the 
owner of an account.

Narrowband In data transmission, the wider the band, the more data it is possible to transmit in a 
given time span. A cable, DSL and ADSL connection to the network provide 
broadband for data transmission. A dialup or ISDN connection typically provide a 
narrow bandwidth for data transmission.

Presence An instant messaging feature that allows users to share information about their 
availability, mood, location and so on.

Proxy See SIP account.
PSTN Public Switch Telephone Network. The traditional land-line phone network.
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RFC Request for Comment. A document that describes an aspect of an internet technology. 
An RFC may be a proposed, draft or full internet standard.

RTP Real-time Transport Protocol. A protocol for delivering the media portion of a data 
transmission over an IP network. SRTP is another media protocol.

Signaling In a VoIP phone call, the information in a call that deals with establishing and 
controlling the connection, and managing the network. The non-signaling portion of 
the call is the Media.

SIMPLE protocol Session Initiation Protocol for Instant Messaging and Presence Leveraging 
Extensions. The instant messaging (IM) protocol followed by Bria Professional. It 
encapsulate the rules for exchanging instant messages.

SIP Session Initiation Protocol. The signaling protocol followed by Bria Professional for 
handling phone calls. 

SIP account An account that provides the user the ability to make VoIP phone calls. The account 
encapsulates the rules and functions the user can access.

softphone address The address used to connect to a SIP endpoint. In other words, the “phone number” 
used in a VoIP phone call. For example, sip:joseph@domainA.com.

SRTP Secure Real-time Transport Protocol. A protocol for delivering the media portion of a 
data transmission over an IP network. SRTP is a secure protocol, which means that 
the media is encrypted. RTP is another media protocol.

TCP Transmission Control Protocol. A transport protocol for delivering data over an IP 
network. Other transport protocols are TLS and UDP.

TLS Transport Layer Security. A transport protocol for delivering data over an IP network. 
TLS is a secure transport protocol, which means that all the data being transmitted 
(signaling and media) is encrypted. Other transport protocols are TCP and UDP.

UDP User Datagram Protocol. A transport protocol for delivering data over an IP network. 
Other transport protocols are TCP and TLS.

URI Uniform Resource Identifier. A name or address that identifies a location on the world 
wide web. A softphone address is a type of URI.

URL Uniform Resource Locator. A URI that both identifies a name or address and indicates 
how to locate it. 

USB device Universal Serial Bus device. A device that follows a specific communications 
standard. A headset may be a “USB type” of headset. 

VAD Voice Activity Detection. A technology that detects if audio is a human voice or 
background noise. Bria Professional includes a feature (Preserve bandwidth on the 
Network panel of the Preferences window) that controls whether audio is transmitted 
when VAD determines that none is actually speaking.

vCard An electronic business card that is often attached to an email. It often appears as a 
“signature” block that identifies the person, their title, and their business.

VoIP Voice over Internet Protocol. A variation of IP used for sending voice data over the 
internet, in other words, used for making phone calls over the internet.

WAV Or WAVE. A file format standard for storing audio on PCs.
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